Support Prolongé PHP

PHP 4.0, PHP 5.2, PHP 5.4, PHP 5.5 et PHP 7.0ne sont plus pris en charge par la communauté PHP. Pour PHP 5.6, le support prendra fin le 31/12/2018. Si vous continuez à utiliser des versions osbolètes de PHP, nous vous avons informé par email que nous ne pouvons continuer à fournir un support technique que dans le cadre de notre Support Prolongé PHP. Dans le cas de PHP 5.6 et PHP 7.0, vous recevrez bientôt plus d'informations de notre part.

Nous vous proposons notre Support Prolongé PHP payant afin que vous ayez le temps de décider de ce que vous voulez faire avec vos sites Web qui utilisent des versions obsolètes de PHP. Vos projets et scripts PHP continueront d'être protégés contre les attaques jusqu'à ce que vous décidiez de passer à une version actuelle de PHP.

Pourquoi suis-je facturé pour le Support Prolongé PHP ?

Nous avons trouvé du contenu PHP sur votre espace Web dans une version ancienne de PHP qui n'est plus prise en charge par la communauté PHP. Vous avez probablement un domaine de votre contrat d'hébergement qui est connecté à une version obsolète de PHP. Si vous voulez changer ce paramètre, procédez ainsi :

  • Ouvrez vos paramètres PHP.
  • Sélectionnez le domaine utilisant une version obsolète et cliquez sur Changer de version PHP. Dans ce contexte, veuillez noter que vous choisissez vous-même la version PHP à utiliser. Sélectionnez alors une version PHP actuelle pour votre ou vos domaine(s).
  • Cliquez sur Enregistrer.

Nous vous recommandons de toujours utiliser la dernière version de PHP. Actuellement, avec PHP 7.2, vous pouvez utiliser sans problèmes les applications les plus populaires.

Pourquoi est-ce que je suis toujours facturé pour le Support Prolongé PHP alors que j'ai choisi un version actuelle de PHP pour tous mes domaines ?

Vous êtes déjà passé à une version PHP actuelle ? Alors vous avez certainement négligé l'avis de résiliation dans vos paramètres PHP. Si vous n'avez plus besoin du Support Prolongé PHP, vous devez le résilier. Vous pouvez également résilier le Support Prolongé PHP via la page Paramètres PHP.

Quand ai-je été informé de l'option Support Prolongé PHP ?

Vous avez été informé du Support Prolongé PHP par email. Veuillez vérifier l'adresse email qui est enregistée chez 1&1 IONOS, et, si nécessaire, entrez une adresse email valide à laquelle nous pouvons vous joindre. C'est la seule façon pour nous de vous offrir le meilleur service possible. Vérifier mon adresse email enregistrée chez 1&1 IONOS.

Pourquoi le Support Prolongé PHP est-il nécessaire ?

Comme la communauté PHP cesse de prendre en charge les versions PHP obsolètes à une certaine date, 1&1 IONOS prend le relais pour la maintenance de ces versions PHP obsolètes. Notre objectif est de vous fournir un service ininterrompu pour vos sites Web et d'éviter qu'ils ne deviennent vulnérables aux pirates informatiques. La maintenance des anciennes versions de PHP signifie un effort d'administration accru sur nos systèmes. C'est pourquoi nous facturons ce service.

Quand est-ce que le Support Prolongé PHP est activé ?

Le Support Prolongé PHP est activé dès lors qu'une version de PHP devient obsolète. Vous pouvez trouver plus d'informations sur notre Support Prolongé PHP et sur l'ensemble du cycle de vie PHP dans notre 1&1 IONOS Community.

Indépendamment de cela, nous vous recommandons de toujours utiliser une version PHP actuelle.

Ai-je besoin du Support Prolongé PHP ?

Voici comment vous pouvez tester :

Si tout fonctionne comme vous le souhaitez, vous pouvez résilier le Support Prolongé PHP en quelques clics via le Service Contractuel. Vous trouverez ici les instructions pour résilier une option.

Sinon, veuillez contacter le Service Client 1&1 IONOS.

Vos scripts ne fonctionnent plus après la conversion ?

Nous vous recommandons alors de repasser à la version PHP que vous utilisiez à la base et de contacter un expert. Dans un tel cas, cela signifie que votre application n'est pas compatible avec la nouvelle version PHP sans ajustements de vos scripts.

Je dois modifier mes scripts pour les adapter à une version actuelle de PHP, mais je n'aurai pas fini avant la date d'activation du Support Prolongé PHP indiquée dans l'email. Que dois-je faire ?

Veuillez d'abord vérifier si une adaptation de vos scripts est vraiment nécessaire. Si des ajustements majeurs sont nécessaires, veuillez contacter notre Service Client 1&1 IONOS.

Vous avez encore des scripts PHP 4.0, PHP 5.2, PHP 5.4, PHP 5.5 ou PHP 7.0 que vous avez toujours voulu utiliser avec 1&1 IONOS ?

Si vous souhaitez utiliser le Support Prolongé PHP comme option supplémentaire pour certains de vos contrats pour lesquels vous n'avez pas reçu d'emails au sujet du Support Prolongé PHP, veuillez contacter directement notre Service Client 1&1 IONOS.